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1. System Block Diagram

1.1.

PowerStudio v2.x and the laters

Host based Software Development Kit for development of the user program and Voice data and IAR
Compiler. A debugging image generated from compiler can be debugged in PowerStudio.

With this software, user can
-

Edit C program and audio wav files

-

Compile and link

-

Download code and voice data into eFlash or serial flash which is connected with the
supported MCU.

-

Run and stop in debug mode

-

View the status of chip or memory

1.2.

ICE

1.2.1. SPICE (Simple but Powerful ICE)
-

USB 2.0

-

Download, upload and debugging

-

Simple Writer for mass production
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1.2.2. DICE
-

USB 2.0

-

Download, upload and debugging

-

Simple Writer for mass production

1.3.

Target System

Boo-Ree supplies the evaluation board of BMC5xx and BMC4xx series
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2. GETTING STARTED
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Getting Started

Welcome to PowerStudioTM !
PowerStudioTM is an intuitive and easy-to-use environment that supports firmware developers to
develop BMCxxx application programs easily and quickly in development stages. Key features of
PowerStudioTM are :
-

C Source Level Debugger

-

Easy-to-use Operation

-

Supporting C , Assembly and .wav file editing/compression

This guide describes how to install PowerStudioTM.
It also provides a tutorial that demonstrates the use of the project facility, the PowerStudioTM
debugger and the add-on tools.
The tutorial is prepared to provide new users with an accessible introduction to the key features of
PowerStudioTM and user guide in embedded software and firmware development.

2.2.

Validating Help Documents

To validate a document on the hard drive, user need to open the
"Doc/PowerStudio10D_R0545.chm" file directly.

2.3.

Host system requirement

-

Host System : Intel Pentium 200MHz or higher

-

Operating System : Windows 2000/XP/VISTA/WIN7 or later

-

Host Main Memory : 64MB or higher

-

Free Disk Space : Minimum 300MB
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Installing PowerStudioTM

It's recommended to select the default options of Installation procedure. The first screen of
installation is as follows.

2.5.

Uninstalling PowerStudioTM

To remove PowerStudioTM from your host system, you can use standard Windows facility. Before
you remove PowerStudioTM, you must shut down all PowerStudioTM programs. To use Windows to
remove PowerStudioTM, select Start>Settings>Control Panel. Then double-click Add/Remove
Programs, select PowerStudio v1.0 from the list, and click the Add/Remove button.
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3. SHORTCUT QUICK REFERENCE GUIDE
3.1.

Keyboard Shortcut Quick Reference Guide

Shortcut

Menu Item

Function Performed

F1

Help

Help System

F2

Edit

Go to Next Bookmark

F3

Edit

Find Repeat

F4

-

Go to Next Error

F5

Debug

Start Debugging

F6

Debug

Debug Stop

F7

Build

Build

F8

Debug

Run Address Break

F9

Debug

Toggle Breakpoint

F10

Debug

Step Over

F11

Debug

Step In

Shift + F2

Edit

Go to Previous Bookmark

Shift + F3

Edit

Find Previous

Shift + F4

-

Go to Previous Error

Shift + F5

Debug

Attach Debugging

Shift + F6

Debug

Reset

Shift + F7

Build

Rebuild All

Shift + F8

Setting

Setting Project Options

Shift + F11

Setting

Setting Environment

Shift + F12

Debug

Go to Address

Ctrl + F2

Edit

Toggle Bookmark
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Ctrl + F4

File

File Close

Ctrl + F5

Debug

Stop Debugging

Ctrl + F6

Debug

Run

Ctrl + F7

Build

Compile

Ctrl + F10

Debug

Step Out

Ctrl + F12

Debug

Skip to Address

Ctrl + Alt + F5

-

Reset Target
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Editor Short Cut

Shortcut

Menu Item

Function Performed

Ctrl + C

Edit

Copy

Ctrl + X

Edit

Cut

Ctrl + V

Edit

Paste

Ctrl + Shift + V

Edit

Paste Buffer

Ctrl + A

Edit

Select All

Ctrl + H

Edit

Replace

Ctrl + G

Edit

Goto Line

Ctrl + “]”

Edit

Goto Matched Brace

Ctrl + ”,”

Edit

Find next '{'

Ctrl + ”.”

Edit

Find previous '{'

Ctrl + J

Edit

Toggle Auto-completing Mode

Edit

Goto Definition

Edit

Popback to Reference

Ctrl + T
Ctrl+Alt+Mouse L button
Click
Ctrl + R
Ctrl+Alt+Mouse R button
Click

Paste the clipboard data and go to a line down at
the same column number.
Ctrl + Alt + V

Ctrl + Alt + X

Edit

Edit

If the buffered string (by ctrl+c) includes any
number at the end, it will increamented by 1 for
each paste.
Delete the selected text and go to a line down at
the same column number and with the same text
selection of same column size.
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4. Start PowerStudio
The initial screen of PowerStudio looks like above.

5. Usage of IAR 8051 C-Compiler with PowerStudio
This document is written in the basis of IAR Embedded Workbench V7.60A for 8051 core.
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6. PROJECT CREATION WITH PROJECT WIZARD
6.1.

New Project Wizard

Project Wizard is consisted of 5 dialogs to
define project properties.
The first dialog is as follow. And follow up each
step depicted in the dialog
Especially, be careful to select register file(.reg)
of the target device in step 3.
In step 4, Boo-Ree currently supports IAR
compiler.
For BMCxxx products, the right device file name should be selected as above figure.
And Currently, IAR Compiler is supported in PowerStudio.
IAR compiler means the "IAR embbeded workbench for MCS-51" from IAR systems. If the IAR
compiler is installed in your PC, then PowerStudio can use the IAR compiler and supports the
source level debugging in PowerStudio. To use IAR compiler, be noticed that you don't need to set
anything in IAR compiler itself.
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IAR compiler setting by Project Wizard

6.2.1. “Project New” dialog
After opening PowerStudio, Click Project->New Project Wizard... or
and the window below will be shown.

tool bar in the main menu.
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6.2.2. “Add File” dialog
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6.2.3. “General” dialog
This setting isn't need to be set. Most of the information will be set automatically and the others
should be set in project environment settings by user.
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6.2.4. “Memory Model” dialog
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6.2.5. “Information” dialog
If there is no errors or nothing to be changed, click "Finish" button.

To use IAR Compiler and debugging in PowerStudio, the followings are also configured.
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IAR Compiler Setting in PowerStudio

As PowerStudio directly supports IAR compiler and linker, the following procedures of the compiler
and linker settings are required here.
Click Project->Project Settings... or

tool bar in the main menu.

Summary :
-

Code Model :
If the program size is less than 64KB, Code should be "Near".
Otherwise, Code should be "Banked". For Banked mode, the program size can be extended
upto 128KB if the selected device has enough memory space.

-

Data Model :
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Large
-

Stack :
Do not use extended stack

-

Locations for constants and strings
CODE memory

To support "boot loader" which is supplied by Boo-Ree, "BMC_SBL" below should be added in the
"Simple Voice" example codes.

To use Simple Boot Loader, updated "CStartup Code" is used so that set "Ignore CSTARTUP in
library" option.
and also set "Override default" option and write the path of b51.xcl ,which is used for BMCxxx.
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Now, you could build codes with IAR compiler and debug in PowerStudio.
For more details, please contact support@boo-ree.com.
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7. Project Open / Close
The project can be opened through several "Open Project" menu.
Project > Open Project...
Project > Project Recent List (1, 2, 3, 4, ....)
In File Explorer, double clock on the project file name (User should choose the PowerStudio for the
default execution program for prj file extension.)
Drag and drop the project file on PowerStudio.
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8. Project Window
8.1.

File Add / Remove

Any files can be added to the current project. Right button click of mouse shows the menu including
"Add Files to Project...". After adding files into project, the files can be opened very easily with
double click on Project file tree.
Source File Folder includes all the C source code (xxx.c) and all the assemly code (xxx.asm). If the
contents of the source file changes, then it need to be compiled again and rebuild.
Header File Folder includes all the .h header files. Even though this header files changes, the Build
command can't detect the modification and may be wrong result of compilation. Therefore, user
should rebuild compilation for this case.
Wave file folder includes all the standard wave files (.wav). User can open them with double click.
When in "Build>Brac Build", all the wave files in Wav File Folder are built to create compressed
object file (.brc), which is only playable format by BMC5xx. If the order of files need to be changed,
then drag and drop the file. But the movement from one folder to the other is not allowed.
Etc File Folder can include any kinds of files which does not affect the compilation result. But this
fold holds so many kinds of files so user can open or access easily.
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Function List

The function names of the project are listed up after project open. Double click on the function name
cause the cursor of editor goes to the subroutine directly.
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Explorer

In the project window, the simple explorer is provided. In this window, the following functions can be
done. The default directory of explorer window is the project path.


File Open



Add to Project



Add to QuickNavi



Remove from QuickNavi



Cut



Copy



Delete



Paste
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QuickNavi

Some directories are frequently accessed in a project. These directories can be added to QuickNavi
window and user can access a file through QuickNavi window.
Directories can be added to QuickNavi through "Add to QuickNavi" command in Explorer window.
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9. Editor Window
9.1.

Editor Windows

The Green Bar is always indicating the current stop line where the program has stopped. Therefore
its location is determined by program running or by the debug functions only. You can’t move the
bar by an arrow key. So let’s call it ‘Stop Bar’ hereinafter.

: Breakpoint mark. If breakpoint mark is set at a line, then debugger will stop at the line when
the processor runs through the line.
: Bookmark
: Reference mark. With a selection on function list window, the editor goes to the text with the
function name and the reference mark is displayed on the left of that function.
: Currentstop mark. The processor stops at the currentstop mark.

9.1.1. Using Bookmarks on the source window
Set a bookmark with "CTRL+F2" or "Edit>Bookmark>Toggle Bookmark".
Go to a bookmark with F2.
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9.1.2. To remove a bookmark
Press CTRL+F2 again at the cursor bar where the bookmark is set.

9.1.3. Find a syntax
Select word > F3
Ctrl+F > Type in a syntax, then F3
Find in Files : Ctrl+Shift+F

9.1.4. Matching Brace
On the Brace ('{', '(', '[', ']', ')', '}'), Ctrl+']' will find the matched brace. Ctrl+Shift+']' makes the
selection of the text between the two braces.

9.1.5. Insert Block (multiple lines) tabs
Sometimes, tabs need to be inserted into several syntax lines. To do this with a key stroke of tab,
the lines need to be selected by mouse or shift+up/down key and press TAB key.

Select paragraph > TAB

9.1.6. Goto Definition and goback to reference
In any project, the definition information can be generated through menu "Build > Build Tag Info".
With this tag information, the colors of tags are changed to blue and user can go to definition or go
back to the reference easily with a key ctrl+t and ctrl+r. Or this can be done easily by "ctrl +
shift+mouse left click" and "ctrl + shift+mouse right click"

9.1.7. Column inserting incremented numbers or strings.
For example, user wants to insert number "01", "02", "03", "04" and "05" between "xxxx" and "yyyy"
at each lines in the following syntax. then please type in the 01 bewteen "xxxx" and "yyyy" in the first
line. Select the "01" and ctrl+c. Then paste five times with ctrl+alt+v. The number is inserted at the
same column position with auto-incremented by 1.
xxxxyyyy
xxxxyyyy
xxxxyyyy
xxxxyyyy
xxxxyyyy
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If the decimal or hexa decimal number is copied, then the number is auto incremented but if the
copied sentence is a simple string, then no incremented is done.

9.1.8. Column Delete
For example, user want to delete the "xy" in the above syntax, the select the "xy" in the first line,
then ctrl+alt+x five times.

9.1.9. Paste Buffer (Multiple Paste)
Sometimes, a selected sentence among several candidates of sentences need to be inserted
frequently. If user copy a sentence with ctrl+c key, then the sentence becomes one of candidates.
To select a sentence among candidates, ctrl+shift+v key helps to do it. The "Select Paste Dialog" to
select a sentence is pop-up and select a sentence.

For no more input to the candidates, please check the "Stop to insert new data into this clipboard"
in the select paste dialog. Then the "copy" function (ctrl+c) does not effect the paste buffer.
If the selected sentence includes multiple lines, this can be paste also but in the selection window,
the text is displayed in a line, which means the carrage return character in the selected sentence is
not displayed in the selection window.
The max number of this buffer is 32.
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Find next brace "{" and match brace

ctrl + "{" find the match barce and ctrl + "}" find next brace. These two kinds of key stroke is very
useful to find any sentence.

9.1.11.

Auto Completing a word

After the tag information is built, user don't need to type in all the complete word which is already
defined in tag info. Select the auto-completing mode in the menu "Edit > Auto Completing" and just
write a word. After two characters are type in, then the auto completing popup window helps to
complete the whole word. If the selected word in popup window is right, then just press space bar
then editor fill in the next key strokes for the word.

9.1.12.

Status Bar
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Tags

The Tags means the keywords to be used for quickly and easily locating the text editor into the
related text. Build->Build Tag Info can generate a cross reference file which lists, in human
readable form, information about the project files. Tag index files are supported by internal editor or
numerous editors such as "vi", which allow the user to locate the object associated with a name
appearing in a source file and jump to the file and line which defines the name.
The tags are generated with all the source and header files. With this information, some string in the
text editor changes its color as follows. Fig 1 shows the text window without tag information. After
building tag information, the color of some words which have tag information changes. And if the
mouse stays long period on the tag word, the related tag information are pop-up on tooltip
subwindow as <fig 2>.

Fig 1. Editor window without tag information
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Fig 2. Editor window with tag information
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9.2.1. Goto Definition
With the tag, the current cursor can be moved easily and simple to the definition of tag. "Clicking
right mouse button" and choosing the "Goto definition" makes the text editor locate in the the
defition of the tag. Try it. And the current position before going to definition can be returned easily
with the menu "PopBack to Ref.".

Fig 3. Goto Definition
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9.2.2. Easy way to use "Goto Definition" and "PopBack to Ref"
With Shift+Ctrl key pressed, left button click of mouse goes to the definition of current tag. To
return to reference, click right button of mouse with Shift+Ctrl key pressed.

9.3.

Auto Completing

The basic idea of "auto completing" is that when a word is typed into the editor, PowerStudio checks
to see if there is any tag that is prefixed by the text written. If there is, then all the candidates
with the written text are displayed in pop-up window and easily complete the word with a space key
stroke. This function starts after at least 2 bytes being typed into.

Fig 1. Editor window without tag information
In the above Fig, when the current word, "UC", is typed into the editor window, PowerStudio finds
itself the best word that is prefixed with the "UC" and display all the candidate words in "Auto
Completing Window". Then user can selects a candidate with UP and DOWN Key, RETURN key or
mouse double click. Or if the selected candidates in "Auto Completing Window" is correct, then don't
need to type continue until the end of word. Non-alphanumeric key (such as SPACE, ';' or '=') which
should be followed by is pressed, then the candidate is inserted into editor window automatically
before the non-alphanumeric character.
To use this auto-completing mode, the main menu Edit->Auto Completing should be chosen first.
If user don't want to choose any candidates, then press ESC. And to make the candidates data
base, tag information is built first with Build->Build Tag Info.
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Build project

Compile
Build
Stop Build
The messages of build goes to build message window.

If there are build errors, then the messages looks like as follows and double click on the
error or warning message line, the source editor window displays the part of source code
which includes the error.
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If any source file is changed, then the build operation detect automatically it and compile
only the modified file. But this build operation can't detect the changes of header file.
Therefore, the header file is changed, user should use rebuild all operation.

9.4.1. Solving the problem of "ASlink-Error Insufficient space in data"
Checking the "Pack IRAM" option in "Project settings >> B51 Linker". Compiler uses 24
bytes of unused register banks for program's variables. In most cases, the linker error will
be disappeared.
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Build Brac

The result of bulid brac is BRAC binary data (.brc) in the path of left-bottom side and the header file
of BRAC.
The BRAC binary data (with ext. of ".brc") should be downloaded to flash memory to play using
"Tools > BRAC Data Writing...".
The header file of BRAC includes the information of BRAC compression/frequency/start addr/size of
each wav file. This information is used for user programming. The explanation about this is in more
details in BMC5xx user's manual.
User should check the error messages in "BRAC Data Information" (Circle part of above figure). If
the file size is too big and the size of compression data is larger than 0x10000, then the
compression can be failed. In this case, user should split the voice file into several pieces. This split
can be done easily with "Selection some part of voice waveform > Mouse Right Click > Create New
Wave with Selection".

9.5.1. Sorting
The order of wave files can be rearranged easily. Mouse clicking on the column header makes the
rearrangement of files depending on the column data, which is respectively sampling frequency and
compression rate.
Click the column header, "Name", "Freq", "N bit Comp" and "Directory" except for "Bytes".
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Before BRAC Build, the Bytes item includes only "-" so that the wave files can't be rearranged.

9.5.2. Multiple wave file resampling
The sampling freqeuncy of a number of wave files can be changed easily with this BracBuild
window as follows.

The result of conversion is shown as follows.

A number of wave files has different sampling frequency from the original. And if press OK, then all
the new wave file information are updated into project information.
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10. Debugging
Start Debugging
Stop Debugging
Reset to Main
Reset (to Zero)
Run
Run Address Break
Stop
Step In
Step Over
Step Out
Run to Cursor
Run to Address
Run to Main
Skip to Cursor
Skip to Address
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10.1. Run / Stop
Run
Run Address Break
Stop
Run
With this command, the program will not stop without stop command. The result of this
command is same as reset of hardware directly.
Run Address Break
The program will stop at the address break or data break.
Stop
The program will stop at any time with this command.
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10.2. Breakpoint
user can set the condition of processor stop. User can set the breakpoint as follows.
maximum 2 of data breakpoints and 2 of address breakpoints
if any of data breakpoints are not used, then this can be used as address breakpoint
User can only concern the number of breakpoint.
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10.3. Step
Step In
Step Over
Step Out
Step In
The program stops at the next statement of the current function. On assembly application or
disassembly mode, the Step In command works as Single Step command.
Step Over
When the program stops at a call statement containing CALL instruction, the Step Over
command makes the program not to step into the subroutine, but directly stop at the next
statement of the CALL statement.
Step Out
When the program steps in a subroutine, the Step Out command makes the program exit
from the subroutine, and stop at the next statement of the CALL statement.
Current version (R0524) of PowerStudio don't support this step out function.
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10.4. Run to
Run to Cursor
Run to Address
Run to Main
Run to Address

User can select the stop address of processor. For above example, program will stop at the
address 0x718.
Run to Main
Program will stop at the begin of main program. This command will be valid between "reset"
and "before the main routine".
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10.5. Skip to
The PC(Program Counter) can be changed with this command. This operation can be done only in
debug mode of Powerstudio. Therefore, this operation should be used only for test purpose.
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11. Debugging Windows
Project View
Output View
Flag List View
Register View
SFR Register View
Watch Register View
Data Memory View
Program Memory View
Variable View
Watch Variable View
Toggle Disassembly
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11.1. Register

The values of BMC50x internal registers are displayed as figure. These registers can be shown in
Data memory window also. In this case, R0 register is mapped to address 0 of iRam.
The values are refreshed every time after debugger stop. Normally the causes of the debugger stop
is as follows
Reset to Main
Reset
Address Break(Run to Address, Run to Main, Run to Cursor)
Step In
Step Over
Step Out
User can change the value of a register with direct type in on this window. User can type in new
value on the value column if double click on the value column.
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11.2. SFR Register

The values of SFR register are shown in this window. The kind of SFR regsiter are assign only
when the project creation. Therefore, any SFR registers can be deleted and inserted after project
creation.
The definition of SFR register is included in xxxxx.reg file. The file name of BMC504 denition is
"BMC504.reg".
The order of registers also are the same as that of definition file.
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11.3. Watch Register

Some of SFR registers and some memory variables can be selected to be displayed in this window.
The number of SFR registers are large so that it's difficult to check the SFR registers in SFR register
window. And to display the SFR register, it takes very long time, even several seconds. To display
registers which user needs to check quickly, this window may be very efficient.
User can select some of SFR register with following window, Settings > Debug Options...
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The drag and drop operation can be another method to select the SFR registers in this window.
PowerStudio accepts a long sentence which includes the name of SFR register as drag and drop
operation and selects only the SFR register to display the values. For example,
DP0L = 0x20;
DP0H = 0x00;
PCON = 0xff;
If the above whole sentences can be drag and drop on the watch register window, then only DP0L,
DP0H and PCON registers are selected to display it.
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11.4. Variable Window
The local variables and global variables are displayed in this window. This window is also
refreshed every time after debugger stop.
But the varibles which has zero of addr value have not correct data value. This is because
the compiler optimized off the variables. If user want to check the value of the variable, then
check "Toggle disassembly" and study the assembly code directly.

Global variables are displayed as following figure. The "+" symbol means the variable
includes more information as following cases.

-

Array

-

Structure

-

Enumeration

-

Union

52

PowerStudio SDK

Ver2.1

53

PowerStudio SDK

Ver2.1

11.5. Watch Variable Window

Any variables can be displayed in this window. user can insert variables with "type in" or "drag and
drop". The variables can be selected only debugging mode.
Type In :
1. Double the name of blank line
2. Type in the variable name

Drag and Drop :
1. Double click (or select) on the variables in the source editor window
2. Drag and drop on watch variable window

And in the variable name field, any simple numerical expression can be inserted such as "cnt+3".
Then the value willl be the sum of the cnt and the number 3.
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11.6. Breakpoint Window

All the breakpoint setting are display on this window. Double click goes to the breakpoint position of
the source editor window. This window display only the address breakpoint.
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11.7. Data Memory Window

All kinds of data memory are display on this window.
The address of this window is physical address. It means the address is not changed depending on
the value of RAMB SFR register.
User can select the kind of memory with selection bar of "Memory Types" and select the address
with "Address to view", "Scroll bar", "Page Down", "Page Up" and arrow key.
With the right click of mouse, the contents of data memory can be saved into a file.
Right Click of Mouse >> Save as file...
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11.8. Program Memory Window

All the program memory is displayed on this window.
The address of this window is physical address. It means the address is not changed depending on
the value of ROMB SFR register.
User can select the address with "Address to view", "Scroll bar", "Page Down", "Page Up" and
arrow key.
With the right click of mouse, the contents of data memory can be saved into a file.
Right Click of Mouse >> Save as file...
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11.9. Output Window
The result of build command is displayed on this window. user can go directly to the error point on
the source editor window with double click on the error message.

The result of Edit > Find in Files is displayed on this window. user can go directly to the finding point
on the source editor window with double click on the message.

All the information of this output window can be copied or saved with right click of mouse button.
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Call stack window

This call stack is available for the debugging with the IAR compiler.
The call stack is displayed as the previous figure. The double click on the function name in call
stack changes all the debugging information as the same as just when the next callee is called.
Next called is displayed on the top most position in call stack window.
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12. Settings
12.1. Environment Settings...
12.1.1.

Display Setting :
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Font Color :
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Com Port :
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Compiler Path :

User can compile the C source code and the Assembly code with IAR compiler through
PowerStudio directly. For this purpose, the home directory the IAR compiler should be registered as
the following figure.

* Refer document “chapter 5.2) Compiler Path Setting of Tenor ApplicationNote”
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Options for Flash Data Manager :

When downloading the data into internal embedded flash, the default memory value can be set in
this window. This means all the memory area except for the user code will be set as this value.
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Fast Debug :

For device BMC51A, PowerStudio has internal special operation to speed up the downloading data
and uploading the debugging information. For the other device, it has no meaning.
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Options for Flash Data Manager :
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Serial Flash :

This settings are required only for device BMC41B. BMC41B extends it's program area up to
external serial flash so that the default settings for external serial flash is required to download the
program to debug. The sentence of cfg file in DeviceConf directory is very easy to follow and if
possible, follow the existing sentence strictly to avoid any confusion.
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12.2. Project Settings...
12.2.1.

General Settings

These settings are very important for IAR compiler. Please select carefully these options for
the user's purpose.
-

Code model :
Near :
the program size can be upto 64KB and normally it is a default options
Banked :
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the program size can be upto 128KB. When banked mode is selected, then the
program running speed can be degraded a little bit, about 5% of the performance.
User need to check the function map in view menu and verify all the location of
function is proper or not. If there are so large size of const data or string, then there
may be some problem of the memory map and cause the wrong result.
-

Data model :
It should be large model

-

The other default option

-

Do not use extended stack

-

XDATA stack reentrant

-

Location for constants and string : Code memory
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The DPTR is used as the data pointer for XRAM code or code area. All the device from
Boo-Ree has two internal DPTRs so that if the number of DPTRs is selected as 2, then the
program execution speed will be faster than as number 1. But the library should be
prepared for this purpose before linking. Except for the performance being important issue,
please use this number as 1.

For the C program which start the main function with the name of "main", all the compiler
has the special library such as CSTARTUP. This function prepares the stack and initialize
the variables of user program. In the case of special booting sequence, this default
CSTARTUP program need to be ignored and repaced with user defined program. The
above figure shows the selection of user CSTARTUP program as default. But for normal
case, this option should be un-selected.

The memory map is defined in xcl file for the linking. Please check the details of the
examples and define carefully each fields. This is defined in IAR compiler manual.
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13. Flash data manager

Any binary data can be downloaded to flash memory of BMCxxx devices. Please follow the
numbering of steps on the dialog.
Step 1. Flash Selection
Selection of flash memory : Internal eFlash or External Serial Flash (start addr is 0x000000)
To select the serial flash, the vendor and product can be chosen carefully. Or the "Detect Serial
Flash" finds the kinds of external flash with the flash ID number. If new serial flash need to
registered, then please make the device configuration file in ~PowerStudio/DeviceConf directory.
The meaning of each sentence in the configuation file is very simple and user can create the correct
configuration file easily.
Step 2. Flash Memory Addr
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Set the start and end address of memory to be downloaded. If a file need to be downloaded,
then don't need to specify the end of address. Just "-1" means downloading "to the end of file".
Step 3. File Selection
Choose the file, which is created in Build Brac, to be downloaded. After selection, the size,
creating date and check sum of file are displayed as the figure.
Step 4. Up / Download
During up/download, the error is displayed on the "error report for up/download and verify"
window.
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14. SimpleWriter
The Spice 2 is the hardware interface between PowerStudio in PC and the Target device
on the hardware board. It is used normally for debugging purpose. But It can be used also
for mass production to burn the ROM code of target chip.
In the menu of "Tools > Power Writer 1 / Simple Writer...", the dialog supplies two
independent functions.
First one is to download data into PowerWriter or SimpleWriter(SPICE 2). The file can be
chosen at the address to be downloaded or several files can be merged into a file through a
button of "Generate a merged file...".
Second one is to start SimpleWriter and check the status of simple writing process through
message of dialog box. This second feature is available only after the first step was done. If
the ROM code data has been downloaded, the "StartSimpleWrtier" starts the burning ROM
data into target chip without the new downloading in the current pop-up dialog.
For the "StartSimpleWriter" function, user can generate the serial number for each devices
which will be stored at the predefined addr. This serial number can be stored at the addr
which contains it's contents with 0xff. User can check the contents of address is 0xff before
this action.
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The red part of the dialog is the functions of downloading and the blue part is the
SimpleWriter function.
The descriptions of each button are as follows.

1. "Add a File…"
Add target .bin files into the Manager.

2. "Delete"
Delete the selected .bin file.
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3. "Delete All"
Delete All of .bin files from the Manager.

4. "Generate a merged file…"
Generate a merged .bin file with .bin files added into the manager.

5. "USB"
If USB is connected well to the PC, the RED color will be changed with Blue color.

6. "File Map Information"
When adding any file into the manager each time, it will be showed in the file Map window.
Start address of each file could be adjusted by double-clicking of the "Start Addr" of each
file in order to avoid overlapping of start address of each .bin file.

7. "Device Selection"
Select the target device to be written with the target .bin file.

8. "Write Protection / Read Protection"
e-Flash write/read protection.

9. "Default Memory Value"
When writing e-Flash with any files, unused area of e-Flash which is not occupied by the
files will be initialized with the setting value.
But, leave it disabled if user don't care the value of the unused area. When disabled, the
downloading speed is faster than using default memory value option enabled.
10. "Download"
Start downloading the file into SPICE 2 or PowerWriter 1 with verification.
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11. "Start "SimpleWriter""
‘USB data cable’, which is currently connected to the PC, to be ‘USB Power cable’. And
to use this function, the Manager program always run together with USB connection and
target set.

12. "Store Serial Number…" : Enable the serial numbering function
Address: The start address where Serial Number will be written into e-Flash.
The 2 lower bits of the Address field should be zero (4 Byte-wise align format).
The memory contents of this address should be 0xff before serial numbering. This 0xff
value can be assigned as const data at that address in user program or the address can be
one of the unused e-Flash area.
If user want to refer to this serial number in his program, the memory address (where Serial
Number will be placed) should be carefully taken care of.
Start Number: starting number of Serial Number. And it can be automatically increased by
every rewriting. But, be noticed that Serial Number MUST consist of 4 Bytes (for example,
0x12345678).

13. "Finish"
Close the SimpleWriter Manager.
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15. Function Map
The physical address of a project can be summurized in Function Map window (Menu: View >
Function Map)

The colorful area is the drawings of all the functions related with the project depending on
it's address. The address is from 0x0000 to 0x10000. If user click any one of the rectangles in the
area, the related function will be chosen in "Function List" window and the detail function text will be
displayed in the Text window.
If user want to know the map of special function which is listed in "Function List", then please
choose the function by mouse click or just typing on it. The function name, it's start address and the
end address are displayed on the above part of this window.
If user selects the target memory model as banked, then the address range will be larger then
0x10000. Normally the end address depends on the max address of the project.
The function map is only available after the project is built successfully. This means that before the
compiling and linking of the project is not done successfully, the function map menu is disabled and
can't be selected.
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16. External Tools
Any external exe files can be executed in PowerStudio very easily. The key points of this function
are as follows.

 Register any execution file
 Run the exec file in any directory
 Display the output message in PowerStudio Output Window
 Automatically run after build operation or before build operation
 The run time argument of the exec file can be input before it's running through PowerStudio
dialog
 Save all the information of current external tools settings into script file
 Load the previous settings of external tools
 Run the external tools with hot key Ctrl+alt+number
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Here are examples how to use external tools. Please follow the bellows. For external tools,
PowerStudio includes MinGW PC compiler which can be used to create the execution files for PC
utilities. First step of the examples shows how to generate execution files with MinGW through
external tools. And the second one is to run the generated execution file and to get the result in the
output window.
If user has any C compiler for PC application, then first step of the examples can be skipped.

1.Make an execution file of Hello.exe


There is a file named hello.c in c:\Program files\PowerStudio\Util\hello.c



To compile this file and to make hello.exe, let’s make a registeration of external tools.



In the External Tools dialog (Tools > External Tools…)

“Add” button to make a new external tool and fill out the dialog as follows
Title

gcc hello

Command

c:\Program Files\PowerStudio\MinGW\bin\gcc

Argument

..\..\util\hello.c –o ..\..\util\hello.exe

Initial directory

c:\Program Files\PowerStudio\MinGW\bin

After this, please press OK button. Then in the main menu > Tools > “gcc hello” menu is created.


Select this “gcc hello” menu.



Then in the build output window, there is a message as follow.

C:\Program Files\PowerStudio\MinGW\bin\gcc.exe ..\..\util\hello.c –o ..\..\util\hello.exe
This message means the compile of the file. If there is another message on build window, then read
the compilation output message on the build window and solve that problem. And check whether
there is a file “hello.exe” in the util directory or not. If there is, then the compile is OK. This is the first
execution of external tools.
2.Make an external tools of hello.exe


Hello.c accepts only one argument of user name and prints out some text.



In the external tools dialog

Add button to make a new external tool and fill out the dialog as follows
Title

hello
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Command

c:\Program Files\PowerStudio\util\hello.exe

Argument

Boo-Ree

Initial directory

c:\Program Files\PowerStudio\util

After this, please press OK button. Then in the main menu > Tools > "hello" menu is created.


Select "hello" menu in the Tools main menu



Then in the build output window, there is a message as follow.

c:\Program Files\PowerStudio\Util\Hello.exe Boo-Ree

Hello PowerStudio User, Boo-Ree !!!
We are glad to see you.
3.Save these external tools as script file
Using "Save" button, user can save these definitions of external tools as file.
4.Load the previous script files for the definition of external tools
With "Load" button, the previous definition can be loaded easily.
5.The script of above examples is saved as a script file in directory of "C:\Program
Files\PowerStudio\Script\Examples.scr". If you don't like to type this examples by yourself, please
load the script file.
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17. UART Console
PowerStudio supports a simple UART console window. To open the console window, use the
"Console Connect" toolbar. All the settings for UART can be set in "Environment Settings".
: Console Connect
: Console Disconnect
The console window will be showed as following figure. The message from UART is displayed in
this window and the characters can be sent through typing characters on this window.
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18. SPICE

SPICE(Simple but Powerful ICE) is the ICE (In-Circuit Emulator) for the MCU products of Boo-Ree
multimedia. It is the hardware interface between PC IDE(PowerStudio) and the target hardware
board. It translates the debug commands from powerstudio into the JTAG information. All the debug
commands go to MCU through SPICE and the result of the execution will be displayed through this
SPICE also.
The other special usage of the SPICE is the eflash writing function, called as SIMPLE Writer. The
details can be read from the SPICE 2 Manual.
Whever SPICE is connected or dis-connected with PC, PowerStudio detects it and display the
connection information in output window.
The Red and yellow LEDs should be on when the USB connection is OK.
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19. Device driver installation of SPICE
When the USB connector of SPICE is connected first with PC, the windows OS detects the new
device as "SPICE" and request to install the USB driver. If windows does not requests it, user
should install through following procedure
Start >> Control Panel >> System >> Hardware >> Device Configuation
Search changes of devices
Select the directory of device driver "PowerStudio/Driver/Usb"
Install
The red LED on the face of SPICE means the successful connection (Good Link) with PC (Not
means the power).

PowerStudio v2.x does not support BMC50x version.
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20. BMC50x Calculator

PowerStudio provides the calculator for UART baud rate and DCO value of audio DAC.

20.1. UART BAUD
UART BAUD rate is described in user's manual of BMC50x. This value depends on the Fosc,
PCON, UxCON0, UxCON1 and UCLK. Given all these values to BMC50x calculator, the CNT0
value of UxBAUD is calculated automatically.

20.2. DCO_VAL
The output audio sampling frequency for DAC should be set through register called as DCO_VAL.
This value depends on the Fosc and the original sampling frequency of voice or sound. With these
values, DCO_VAL is calculated in the BMC50x calculator.
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21. Upgrade SPICE / PowerWriter

The firmware of SPICE can be upgraded. These tools are very flexible and configurable so that the
functions of these tools can be added and upgraded.
The upgrading should be started from the downloading the upgrade files from www.booree.com/donwload site.

File Name and meaning
SP2_Upgrade_Firmware_1113.upg
Upgrade files for SPICE
The number of 1113 means version number
User can know the version numbers of hardware and the upgrade file in PC. If possible, please use
the new version of upgrade file.
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22. Connection Problem with target board
22.1. Error Message :


FAIL : Initialize connection

SimpleICE or PowerICE is not connected with PC.



FAIL : Target reset (Please Check the Power of Target Board)

SimpleICE or PowerICE is connected with PC. But the ICE is not connected with target board or
there is a problem with BMC50x chip, for example no clock.

22.2. Important NOTICE :
The signal named TRST of JTAG between target board and ICE should be connected with the reset
signal of target board.

The reset signal is normally connected with RESET switch and RC circuits. BUT the time constant
of RC circuits should be less than 500 usec.
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